Show cool things you have done with our products


Post by Dev_Coppelis »

how can i implement Crud operations with Ms Import ?

Post by mats »

Please explain a bit more what you are trying to and what the problem is? We have a CRUD manager class (see docs) that handles reading/writing data. https://www.bryntum.com/docs/gantt-for- ... rudManager

Post by Dev_Coppelis »

i already added CrudManager Class to Js folder and created an object of it in MSProjectGantt so data are loaded successfully but while saving i got some errors
here are screenshots
demo structure.png
demo structure.png (12.83 KiB) Viewed 4959 times
adding crud.png
adding crud.png (7.85 KiB) Viewed 4959 times

Post by mats »

Ok, we can't help much when you just say "i got some errors". Please see: viewtopic.php?f=1&t=772

Post by Dev_Coppelis »

sorry for being not clear on my question
here is the error
it happens before sending data to api
Crud Error.png
Crud Error.png (70.35 KiB) Viewed 4959 times

Post by pmiklashevich »

Hello,

Is this issue already fixed by Arcady or it's different? (viewtopic.php?f=4&t=9914)
If not, please provide a test case so we can check. Also we need data from you and steps, how to reproduce the issue. When you zip your code, please remove all libraries. Just leave the sample code.

Thanks,

Pavlo Miklashevych
Sr. Frontend Developer


Post by pmiklashevich »

Also I've checked the code. The error happens in Sch.data.Calendar.convertMSDurationToUnit when it tries to read property DAY of this.unitsInMs.
this.unitsInMs['DAY']
this.unitsInMs is null by default, but it's get filled with values in constructor. So need to debug to see why it's not filled up.

Pavlo Miklashevych
Sr. Frontend Developer


Post by Dev_Coppelis »

pmiklashevich wrote:Hello,

Is this issue already fixed by Arcady or it's different? (viewtopic.php?f=4&t=9914)
If not, please provide a test case so we can check. Also we need data from you and steps, how to reproduce the issue. When you zip your code, please remove all libraries. Just leave the sample code.

Thanks,
ok i will dowbload the version and apply it then inform you.
thanks for support

Post by Dev_Coppelis »

pmiklashevich wrote:Hello,

Is this issue already fixed by Arcady or it's different? (viewtopic.php?f=4&t=9914)
If not, please provide a test case so we can check. Also we need data from you and steps, how to reproduce the issue. When you zip your code, please remove all libraries. Just leave the sample code.

Thanks,

i checked the nightly build but it was in 23-09-2018 and no updates .

Post by pmiklashevich »

Hm, interesting.. We will take a look! Thanks for bringing our attention to this problem! Will let you know as soon as it's fixed. (or 6.0.4 is out)

Pavlo Miklashevych
Sr. Frontend Developer


Post Reply