error on coverage cli

Get help with testing, discuss unit testing strategies etc.


Post Reply
User avatar
Hakim
Posts: 58
Joined: Fri Apr 26, 2019 3:00 pm

error on coverage cli

Post by Hakim »

Hi all,
I am facing an issue with the cli below

Code: Select all

siesta-5.5.0-standard/bin/webdriver http://localhost:1841/myApp/test/Siesta/test.html --include UT --coverage-report-format=HTML --coverage-report-dir report --browser=firefox --headless

Here is the error:
Image

I can't understand why that's happening. It is used to work without any problem


User avatar
Hakim
Posts: 58
Joined: Fri Apr 26, 2019 3:00 pm

Re: error on coverage cli

Post by Hakim »

Hi,
Any idea on the issue?


User avatar
Hakim
Posts: 58
Joined: Fri Apr 26, 2019 3:00 pm

Re: error on coverage cli

Post by Hakim »

Hi,
In fact, a third-party library was used by one of developers in my team. I went deeper and figured it out. The library is

: with .js extension. It is just causes the error on generating report.
There is no problem when executing tests normally but report can't be generated . So, please consider those kind of issues in the next release.
Thanks


User avatar
nickolay
Core Developer
Core Developer
Posts: 3466
Joined: Mon May 16, 2011 10:48 am

Re: error on coverage cli

Post by nickolay »

Hi,

If its a 3rd-party library, it can be excluded from the coverage report using the --nyc.exclude command line option.

We offer training in both Ext JS and our products, read more here.
Read the API documentation

Post Reply