Search found 58 matches

Could you fix the vulnerability warning in "siesta-lite": "^5.5.1"? npm audit === npm audit security report === Manual Review Some vulnerabilities require your attention to resolve Visit https://go.npm.me/audit-guide for additional guidance High Prototype Pollution in node-forge Package node-forge P...
Ok, good to know. And Puppeteer works fine? Puppeteer downloads chrome 78 - and seems to works fine . I had to pass --browser-arg no-sandbox as parameter, cause in docker container it runs as root. Without this chrome fails to run. Webdriver requires chrome >= 79, I tried with 79, 80 builds and the...
My conclusion is that the issue is related to the webdriver, chrome version or something related to them. I've tried different options to run this, same result. Webdriver with chrome is failing in the docker container.
Ok, I get the feeling it has something todo with the chrome installation that webdriver is using. I just gave it a shot with firefox and ... it works :) root@60653ef88db2:/srv/tools/siesta-5.3.2-trial/bin# ./webdriver 127.0.0.1:88/senchaws/packages/local/ipdu/tests/indexr-no-ui.html --headless --bro...
If I run it with puppeteer then it seems to work. Never tried it with puppeteer. Now webdriver vs puppeteer, would you recommend using puppeteer over webdriver? root@60653ef88db2:/srv/tools/siesta-5.3.2-trial/bin# ./puppeteer 127.0.0.1:88/senchaws/packages/local/ipdu/tests/indexr-no-ui.html --browse...
Hi, Hard to say, the preload failure indicates its a legitimate 404 error, detected by browser and reported by Siesta. Possibly a file is just missing? or some access directives in the webserver aren't correct? Can you try reproducing this error with Siesta 5.3.1 ? No files are missing. I thought s...
I am playing around with your trial webdriver and I have noticed a problem. I created a docker container where I want to run the tests but they fail if I run them in the a docker container. If I run the tests on a unix host similar to the docker container all good. I am getting preload errors "fail ...
There are several vulnerabilities errors in npm when using siesta. Any ideas on fixes? It seems that all is coming from the handlebars package. package.json { "devDependencies": {}, "scripts": {}, "dependencies": { "siesta-lite": "^5.3.1" } } npm i siesta-lite npm WARN saveError ENOENT: no such file...
Part #2. Can't upload more than 3 files. Also the chrome notice: A cookie associated with a cross-site resource at https://bryntum.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Se...